त्रुटि को ठीक करें: आपका PHP अधिष्ठापन MySQL एक्सटेंशन को गायब करता है जो कि वर्डप्रेस द्वारा आवश्यक है

"आपका PHP इंस्टॉलेशन MySQL एक्सटेंशन को गायब कर रहा है जो कि वर्डप्रेस द्वारा आवश्यक है"एक गलती कई ब्लॉग मालिकों और वेबसाइटों की पकड़ है वर्डप्रेस.
यह चिंता का कारण नहीं है। MySQL एक्सटेंशन का अभाव पीएचपी खरोंच, वीपीएस या समर्पित सर्वर से स्थापित ऑपरेटिंग सिस्टम की विशिष्ट है, जहां PHP एक्सटेंशन इंस्टॉलेशन पैकेज का हिस्सा नहीं थे। यह समस्या दोनों पर मौजूद है उबंटू और CentOS। इस परिदृश्य में, समस्या केवल एक PHP अद्यतन और मॉड्यूल स्थापना के साथ हल की गई है "php-mysqlपर क्लिक करें।
PHP को अपडेट करें और उबंटू पर MySQL एक्सटेंशन इंस्टॉल करें

apt-get update
apt-get install php-mysql

PHP को अपडेट करें और CentOS पर MySQL एक्सटेंशन इंस्टॉल करें

yum update
yum install php70w-mysql

इस कदम के बाद, अपाचे सेवा को फिर से शुरू करें या nginx.

मुझे उस परिदृश्य का भी सामना करना पड़ा जहाँ यद्यपि MySQL एक्सटेंशन PHP में मौजूद है, वर्डप्रेस पर बनाए गए एक ब्लॉग ने त्रुटि दिखाई "आपका PHP इंस्टॉलेशन MySQL एक्सटेंशन को गायब कर रहा है जो वर्डप्रेस द्वारा आवश्यक है"। ज्यादातर बार, वर्डप्रेस को इंस्टॉल करते समय त्रुटि होती है। इस बार, हालांकि, वह एक ब्लॉग पर दिखाई दिया जो कई वर्षों से सक्रिय था।
इस स्थिति में, मैंने पाया कि समस्या PHP मॉड्यूल नहीं है, लेकिन वर्डप्रेस का बहुत पुराना संस्करण है, जो अब PHP 7.4.4RC1 के साथ संगत नहीं है। नवीनतम संस्करण में एक साधारण वर्डप्रेस अपग्रेड ने त्रुटि को हल किया।

त्रुटि को ठीक करें: आपका PHP अधिष्ठापन MySQL एक्सटेंशन को गायब करता है जो कि वर्डप्रेस द्वारा आवश्यक है

लेखक के बारे में

छल

गैजेट और आईटी का मतलब है कि सब कुछ के बारे में भावुक, मैं 2006 से स्टील्थसेटिंग्स.कॉम पर खुशी के साथ लिखता हूं और मुझे आपके साथ कंप्यूटर और मैकओएस, लिनक्स ऑपरेटिंग सिस्टम, के बारे में नई चीजों की खोज करना पसंद है Windows, iOS और Android।

एक टिप्पणी छोड़ दो