अक्षम और सक्षम क्लासिक गुटेनबर्ग संपादक वर्डप्रेस 5.0 +

क्या आप गुटेनबर्ग को अक्षम करना चाहते हैं और क्लासिक वर्डप्रेस प्रकाशक पर वापस जाना चाहते हैं?
गुटेनबर्ग
क्लासिक संपादक को प्रतिस्थापित करने के लिए हाल ही में WordPress में पेश किया गया एक संपादन टूल है। इसमें अधिक गतिशील और सैद्धांतिक रूप से अधिक सहज इंटरफ़ेस है, लेकिन कई प्रकाशकों को वर्डप्रेस के क्लासिक प्रकाशक की तुलना में उपयोग करना अधिक कठिन लगता है। इसके अतिरिक्त, यदि आप पुराने वर्डप्रेस थीम का उपयोग करते हैं जिसे नए गुटेनबर्ग संपादक को सुनने के लिए अपडेट नहीं किया गया है, तो सभी प्रकार की त्रुटियों का सामना करना बहुत संभव है। हमारे मामले में, वर्डप्रेस 5.0 पर गुटेनबर्ग संपादक एक असली उपद्रव था। मसौदे को संपादित करना लगभग असंभव था। पाठ पूरी तरह से नहीं चुना जा सका, और पृष्ठ में संरेखण, पैराग्राफ में, कर्सर छोड़ दिया और कहीं और लिखना शुरू कर दिया। अजीब।
हमारी अनुकूलता में, जो लोग साइट पर लिखते हैं उन्हें सरल, सहज और आसान विकल्प की आवश्यकता होती है। गुटेनबर्ग ने हमें अब तक इनमें से कोई भी रिसाव नहीं दिखाया। परिवर्तन के प्रभाव होने के लिए, क्लासिक के साथ संपादन के 12 वर्षों से संभवतः बेहतर है।

हम अकेले नहीं हैं वर्डप्रेस डाउनलोड प्लगइन्स के आधिकारिक मंच पर, मैं उन लोगों की अत्यधिक सराहना करता हूं जो नई सुविधा के दौरान गुटेनबर्ग को अक्षम करने में मदद करते हैं WordPress के 5.0 बहुत सारी नकारात्मक समीक्षा है। यह सच है कि उनमें से अधिकतर ने नकारात्मक स्कोर दिया है WordPress थीम्स जो गुटेनबर्ग के साथ गतिशील लाइव इंटरफेस के लिए तैयार नहीं हैं।

इस लेख में हम आपको दिखाएंगे वर्डप्रेस में आप गुटेनबर्ग को कैसे अक्षम कर सकते हैं वर्तमान विषय और इसके लिए 5 क्लासिक संपादन / प्रकाशन संपादक पर लौटें.

सबसे पहले, आपको पर्याप्त फ़ाइल संपादन अधिकारों की आवश्यकता है functions.php संपादन अधिकारों के साथ वर्तमान विषय (सक्रिय) या एफ़टीपी पहुंच का।

खुला functions.php और लाइन जोड़ें:

add_filter('use_block_editor_for_post', '__return_false');

फ़ाइल को सहेजें फिर "पोस्ट"→"नया जोड़ें"। आप संपादक को नोटिस करेंगे गुटेनबर्ग वह गायब हो गया और क्लासिक के साथ गुमराह हो गया।
यह सबसे आसान तरीका है और किसी भी वर्डप्रेस प्लगइन की स्थापना की आवश्यकता नहीं है। वर्डप्रेस 5.0 पर सफलतापूर्वक परीक्षण किया गया। यदि यह वर्डप्रेस के बाद के संस्करणों में बदला जाएगा, तो हम इस आलेख के अपडेट के साथ वापस आ जाएंगे, यह दिखाएंगे कि इसे कैसे अक्षम किया जा सकता है गुटेनबर्ग.

यदि आप 5.0 के पुराने वर्डप्रेस संस्करण का उपयोग कर रहे हैं, तो निम्न पंक्ति को functions.php में जोड़ें:

add_filter('gutenberg_can_edit_post', '__return_false', 5);

स्वचालित (वर्डप्रेस डेवलपर्स) वर्तमान में ऐसा करने के लिए एक प्लगइन की सिफारिश करता है, लेकिन क्लासिक संपादक केवल 2021 तक उपलब्ध होगा। हम उस पल के बाद देखेंगे कि हम क्लासिक संपादक को वर्डप्रेस में कैसे रख सकते हैं। तब तक गुटेनबर्ग के लिए "दोस्ताना" बनने का विकल्प भी है।

अक्षम और सक्षम क्लासिक गुटेनबर्ग संपादक वर्डप्रेस 5.0 +

लेखक के बारे में

छल

सब कुछ है कि गैजेट और आईटी 2006 की ख़ुशी से stealthsettings.com लिख सकते हैं और मैं कंप्यूटर और MacOS, लिनक्स, विंडोज, iOS और Android के बारे में आप के साथ नई चीजों की खोज करना चाहते के बारे में भावुक।

एक टिप्पणी छोड़ दो

यह साइट स्पैम को कम करने के लिए अकिस्मेट का उपयोग करती है। जानें कि आपका डेटा कैसे संसाधित किया जाता है.